EDV Workshops

Matrixformeln

Eine schnelle Berechnungsmöglichkeit bietet Excel mit den sogenannten Matrixformeln. Die Funktionsweise der Matrixformeln soll an folgendem Beispiel dargestellt werden. Nutzen Sie zum Nachvollziehen die Datei "matrixformeln-und-funktionen.xlsx".

Excel Matrixformel Einführung

Das Beispiel zeigt, wie man in einer Zelle die Multiplikation der beiden Spalten C und D durchführen und deren Produkt summieren kann.  Die Formel lautet:

=SUMME(C3:C5*D3:D5)

abgeschlossen wird die Eingabe mit der Tastenkombination STRG + Umschalten + ENTER. Es werden geschweifte Klammern um die Formel gesetzt, was Excel anweist Zeile für Zeile vorzugehen. Die linke "Spalte" wird mit der rechten "Spalte" Zeile für Zeile multipliziert, die Ergebnisse jeweils addiert.

Stellen Sie das Beispiel nach und betrachten Sie, was passiert, wenn Sie nur die ENTER Taste nutzen um die Eingabe abzuschließen. 

Betrachten wir an dieser Stelle die SUMMENPRODUKT-Funktion von Excel?

Öffnen Sie folgendes Beispiel oder erstellen Sie es kurz in einer neuen Arbeitsmappe:

Excel Matrixfunktion SUMMENPRODUKT

Die Funktion SUMMENPRODUKT macht genau das selbe. Hier werden mehrere Bereiche (Achtung immer "Paarweise") angegeben, die gegeneinander multipliziert und dann summiert werden.

Eine sehr gute Einführung hat Bernd Berteils auf der Rhein-Rhur Plattform geschrieben. Ebenfalls empfehlenswert ist wieder Excel Online mit der "Reise ins Matrixland".

Weitere Informationen im Web

Übung - Tennisturnier

Um ein wenig mit verschachtelten Funktionen zu arbeiten schauen Sie sich doch die Übung "Tennisturnier" an. Die Übungsdatei "uebungen-tag-05-tennisturnier.xls" enthält alles notwendige.

Übung Tennisturnier