EDV Workshops

WENN Funktion

Die wohl mächtigste Funktion innerhalb von Excel ist die Wenn-Funktion. Die WENN-Funktion wird unter anderem von den Funktionen UND() und ODER() begleitet, daher wird dieser Artikel auch diese beiden Funktionen beleuchten.

Excel - Wenn-Funktion

Ausgehend von diesem Beispiel soll die Wenn-Funktion erläutert werden. Um dem Beispiel zu folgen, schreiben Sie bitte das obige Beispiel ab.

 

 Flussdiagramm - Entscheidung

In der Spalte "G" soll nun die Entscheidung eingefügt werden, ob jemand "Bestanden" hat oder "Durchgefallen" ist. Hierzu fällt eben gerade die Entscheidung an. Im oben abgebildeten Flussdiagramm ist die Entscheidung "Orange" dargestellt.

Mit den bisher bekannten Mitteln (Summe, Min, Max, Anzahl, Anzahl2, Runden, usw.) können wir noch keine Entscheidungen in eine Berechnung einfließen lassen. Genau hier kommt die WENN-Funktion ins Spiel.

Die WENN-Funktion kann anhand einer "Prüfung" die Entscheidung vornehmen, ob in G5 "Durchgefallen" oder "Bestanden" eingetragen wird. Die allgemeine Syntax der WENN-Funktion sieht wie folgt aus:

=WENN(Prüfung;Dann-Wert;Sonst-Wert)

Positionieren Sie die "Aktive Zelle" in der Zelle G5 und geben Sie folgende Formel ein:

=WENN(F5<50%;"Durchgefallen";"Bestanden")

Somit wird die Entscheidung "Bestanden" oder "Durchgefallen" einzutragen von der Prüfung "F5 < 50%" getragen.

Betrachten Sie die Notation. Wie wird die WENN-Funktion eingetragen!

Die WENN-Funktion

Die WENN-Funktion gibt - abhängig von der Prüfung - "Bestanden" oder "Durchgefallen" zurück. Achten Sie darauf, dass die Funktion Texte zurückgeben kann. Hierbei muss der Text, der zurückgegeben wird, in Anführungszeichen gesetzt werden.

Weiteres Beispiel:

Beispiel Bescheinigung - Wenn Funktion

Im oben Abgebildeten Beispiel gibt die WENN-Funktion ein "Nötig" aus, wenn das Alter unter 18 Jahren ist und ein "Nicht nötig", wenn das Alter 18 und höher ist. Probieren Sie es gleich aus. Beachten Sie dabei die Schreibweise der WENN-Funktion. Wenn die WENN-Funktion Texte ausgeben soll, müssen diese in Anführungszeichen geschrieben werden (genau wie im ersten Beispiel "Bestanden" und "Durchgefallen").

EXKURS "ZÄHLENWENN"-Funktion:

Dies ist eine gute Gelegenheit gleich die Funktion "ZÄHLENWENN()" kennen zu lernen.

ZählenWenn-Funktion

Die Funktion "ANZAHL" zählt alle Felder, deren Inhalt "Zahlen" sind (so würde die Funktion "=ANZAHL(B:B)" alle Felder der Spalte B zählen, die Zahlen enthalten - Ergebnis wäre hier 5). Die Funktion "ANZAHL2" zählt alle Felder die nicht leer sind (so würde die Funktion "=ANZAHL2(B:B)" alle Felder der Spalte B zählen, die nicht leer sind - Ergebnis wäre 6 ... in der Zelle B1 ist nichts drin ... der Text steht in A1!).

Die Funktion ZÄHLENWENN zählt die Felder nur, wenn der Inhalt eine bestimmte Bedingung erfüllt (so zählt die Funktion "=ZÄHLENWENN(C4:C8;"Nötig")" alle Felder, die im Bereich von C4 bis C8 ein "Nötig" stehen haben.

Weitere Infos zur Funktion "ZÄHLENWENN" finden Sie im Artikel "ZÄHLENWENN".

ENDE EXKURS "ZÄHLENWENN".

Betrachten wir uns im nächsten Schritt die Funktionen "UND()" und "ODER()".

UND und ODER Funktion in Excel

Schreiben Sie die Werte der Zeile 2 in eine eigene Tabelle und "spielen" Sie ein wenig mit den Möglichkeiten. Schauen Sie sich die Beispiele an. Die UND- und die ODER-Funktion werden später innerhalb der Prüfung der WENN-Funktion genutzt.

Wenn Sie die Tests mit den Vergleichen durchgeführt haben, nutzen Sie nun die Vergleiche in der Prüfung der WENN-Funktion.

WENN-Funktion mit UND und ODER

Nutzen Sie ein leeres Tabellenblatt. Schreiben Sie in die zweite Zeile wieder die Werte. Notieren Sie dann in der ersten Spalte die Werte für Preis A und Preis B. Trainieren Sie dann die WENN-Funktion.

Dann noch:

  • Man kann bis Excel 2003 max. 7 mal verschachteln
  • Ab Excel 2007 kann man bis zu x mal verschachteln
  • Man kann bis Excel 2010  nur max. 8192 Zeichen pro Formel nutzen

 

excel max formellaenge 01

 

Weitere Verweise im Web